Back to overview
We are experiencing issues with Reports, Webhooks, Dashboards
Oct 17, 2025 at 6:00pm UTC
Affected services
WorkBright Application & API
Resolved
Oct 17, 2025 at 6:32pm UTC
We have identified the root cause and we are back to normal
Affected services
Created
Oct 17, 2025 at 6:00pm UTC
Reports, Webhooks, Dashboards are unavailable until further notice.
Affected services