Back to overview
Maintenance
Server Downtime, Thursday, June 18, 2026, 8:00–8:30 PM MST
Jun 19, 2026 at 2:00am UTC
–
Jun 19, 2026 at 2:30am UTC
Affected services
WorkBright Application & API
Resolved
Jun 19, 2026 at 2:30am UTC
Maintenance ended
Affected services
Created
Jun 19, 2026 at 2:00am UTC
From 8:00 PM – 8:30 PM MST on June 18, 2026, the WorkBright website and API will be unavailable for server infrastructure maintenance and improvements. We apologize in advance for any inconvenience that may be caused.
Affected services